Solved : Unable To Install vmnet On VMware Workstation 8.0.2

Posted by

Kemarin saya hendak uji coba VMware ESXi 5.5 diatas mesin Virtual dengan pola nested. Biasanya saya menggunakan VirtualBox sebagai server Virtual untuk melakukan uji coba tersebut. Pada pertengahan instalasi VMware diatas VirtualBox, didapatkan info bahwa tidak ditemukannya mode Virtualization Technologi dan instalasipun tidak dapat dilanjutkan. Dengan begitu, maka saya  download dan install VMware Workstation yang dapat menjalankan mode nested terhadap VMware ESXi yang hendak saya install. Sistem Operasi desktop yang biasa saya gunakan sehari-hari adalah OpenSUSE 12.3 64 bit. VMware Workstation dapat diinstall sebagai mana mestinya, namun pada saat akan menjalankan-nya terdapat pesan seperti pada gambar berikut :

workstation-compile

Untuk mengetahui apa yang menjadi masalah, saya menjalankan perintah berikut pada konsole/terminal

vmware-modconfig --console --install-all

Setelah menjalankan perintah diatas, diketahui bahwa vmnet tidak dapat diinstall seperti terlihat pada contoh gambar dibawah :

workstation-vmnet

Setelah mencari diinternet, ternyata harus melakukan patching terlebih dahulu terhadap VMware Workstation yang baru saja diinstall. Berikut tahapan yang dapat dilakukan

cd /opt
wget -c http://weltall.heliohost.org/wordpress/wp-content/uploads/2012/04/vmware802fixlinux340.tar.gz
tar -zxvf vmware802fixlinux340.tar.gz

Setelah di extract, file patch tersebut menghasilkan 2 buah file yaitu patch-modules_3.4.0.sh dan vmware3.4.0.patch. Berikan hak akses eksekusi terhadap file patch-modules_3.4.0.sh untuk melakukan patching

chmod +x patch-modules_3.4.0.sh
./patch-modules_3.4.0.sh

Eng ing eng, akhirnya VMware Workstation dapat saya gunakan untuk simulasi instalasi dan penggunaan VMware ESXi maupun Proxmox.

Silakan dicoba dan semoga bermanfaat 😀

Catatan : Apabila file patch tersebut tidak ada, dapat juga download pada link berikut : Patch vmware802fixlinux340

Sumber Tulisan : http://weltall.heliohost.org/wordpress/2012/04/01/vmware-workstation-8-0-2player-4-0-2-and-7-1-x3-1-x-fix-for-linux-kernel-3-4-0/

Leave a Reply

Your email address will not be published. Required fields are marked *